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MAIN CHANGES

RT-LAB 11 is the result of a lengthy period of considerable efforts from OPAL-RT developers.
The new version of this well-known real-time simulation software environment is more robust
than the previous ones and attempts to repair known issues and to enhance the user
experience. A major new release of any software usually demands some adaptation from users
and this document intends to summarize specific changes related to software operation, in order
to facilitate migrating from previous versions to RT-LAB 11.

RT-LAB comes with further detailed documentation, such as an Installation Guide, User Guide,
C API and Python API references. For any questions not covered by these documentations,
please contact the OPAL-RT support team (support@opal-rt.com).

RT-LAB no longer requires administrator privileges to be used, it can be operated by any user.
This scenario is much more consistent with most institutional and academic environments.
Administrator privileges will be required only in particular situations, such as: first launch of RT-
LAB, MATLAB auto-repair operation and model compilation after changing the current MATLAB
version.

In previous RT-LAB versions, the MetaController had to be manually launched and closed. The
behaviour of this important component has been reviewed in this new version: from now on,
launching / closing RT-LAB will automatically launch / close the MetaController.

The management of MATLAB versions has been improved in this version of RT-LAB.
Previously, installing MATLAB after having installed RT-LAB could lead to some unpleasant
issues. Now, these products can be safely installed in any order; every time RT-LAB launches a
MATLAB instance, it verifies whether the required files already exist in the appropriate folder. If
these files are not there, RT-LAB creates them (this requires administrator privileges).
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The 64-bit versions of MATLAB are not enabled by default because some RT-LAB features are
not supported by those versions. However, if your application needs a 64-bit version of
MATLAB, you can enable RT-LAB to show these versions by checking the following option:

Window > Preferences > RT-LAB > Simulation tools > MATLAB > Enable selection of 64-bit
MATLAB versions

MATLAE e g

Here are the MATLAE and Simulink preferences:
Basic

[] Use sarne MATLAB version as model.

[T Enable selection of 64-bit MATLAE versions.
Current MATLAE version:

[Matlab R2011B (32 Bit) (7.13) -

Advanced
MATLAB and Simulink target root directory (Example: fust/matlab/vi.7):

Automatic - B

RTW template make file (TMF):

Automatic - B

RTW target language compiler file (TLC):

Automatic - B

’ Restore Defaults ] [ Apply ]

| ok || cancel |
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All components that enumerate MATLAB versions will be affected by this configuration. For
example, the figure below shows the contents of the MATLAB icon (on the toolbar) after
enabling the 64-bit versions.

|-G |d|e-a-| -

Open J Matlab R2011E (32 Bit) (7.13)

Matlab R2013A (54 Bit) (8.1) [Not installed]
Matlab R2012E (54 Bit) (8.0) [Not installed]
Matlab R2012A (64 Bit) (7.14) [Not installed]
Matlab R2011B (64 Bit) (7.13) [Not installed]
Matlab R2011A (54 Bit) (7.12) [Not installed]
Matlab R2013A (32 Bit) (8.1) [Not installed]
Matlab R2012E (32 Bit) (8.0) [Not installed]
Matlab R2012A (32 Bit) (7.14) [Not installed]
@ Matlab R2011B (32 Bit) (7.13)

RT-LAB targets accept two types of licenses for model compilation permissions:
e Runtime license: allows the user to use all RT-LAB features, except model compilation.
This license is for users who only need to run their models on the target.
o Development license: allows the user to perform all build steps on the target, including
model compilation.

If you wish to compile a model, but your target has a runtime license, the build process will
display the following message. If this is your case, please request a development license.

rﬁ Problem Occurred I. = | (5] |_i:?-1

I.-"'_"“‘-.I 'Building model' has encountered a problem.

S Error while building model rtdemcol

oK || << Details

Error while building model rtdemol -
The license on target does not allow you to compile a model,
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The following files have been moved from their previous folders to more intuitive locations:

e Controller.log used to be a single logfile common to all projects, stored in the folder
%RTLAB_ROOT%/common/bin/. From now on, each project has its own separate file,
stored in its folder. The size of such file is limited to 10MB (editable in Hardware.config);
RT-LAB will automatically create another file if the current one exceeds maximum size.

e Hardware.config, MetaController.state and other files have been moved from
%RTLAB_ROOT%/common/bin to %ProgramData%/OPAL-RT/RT-LAB/%VERSION%/.

For models containing asynchronous processes and/or S-Functions, RT-LAB automatically
detects the required files for such components and adds them to the list of extra files. In order to
repair known issues related to the mixture of asynchronous processes and S-Functions files, the
“Files Properties” page of the model editor has been reviewed, allowing the user to choose the
category of extra files. The category is automatically detected by RT-LAB but can be changed by
the user. If an extra file is not automatically added to this list, the user can also perform this
operation manually. Please refer to the User Guide for further information.

Files Properties

[¥] Enable automatic file retrieval
(V] Allow file retrieval during simulation

[V] Build intermediate tree on file retrieval

File retrieval root directory: ../myfiles Lj @

Name Mode Category Transfer Time Subsystems Add
LAfilenamel.bt ascii Other Before load All

Delete

| Delete Al

Edit

i
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Improving the way asynchronous processes are managed by RT-LAB has required the use of
additional libraries when compiling the user code. For that reason, existing custom makefiles
used by asynchronous processes must be updated as shown below.

The following lines:

LIBPATH =-L.

LIBS := -IOpalAsyncApiCore -IOpalCore -IOpalUtils $(LIB_TARGET)

Must be replaced, respectively, by:

LIBPATH =-L. $(OPAL_LIBPATH)

LIBS := -IOpalAsyncApiCore -IOpalCore -IOpalUtils $(LIB_TARGET) $(OPAL_LIBS)

Trying to compile an asynchronous process without editing its makefile will lead to the following
error message window:

e "

# Problern Cccurred EI@

| ‘Building model' has encountered a problem.

= Error while building model AsyncDemo

oK | [ << Details

Error while building model AsyncDemeo »
There are one or more makefiles for Asynchronous Process
that aren't valid.

To be compatible, your makefiles must have the macro
S(OPAL_LIBS) to the list of libraries and 5(OPAL_LIBPATH] to
the list of library paths.

If you use makefiles based on our examples, you just have to:
- add 5(OPAL_LIBPATH) at the end of LIBPATH declaration
- add S$(0PAL_LIBS) at the end of LIBS declaration

The compilation log will also display the following message:
———————————————————— Validating sources files -------——-—--—--———-————————

C:/Users/../AsyncProcess.mk... Missing $(OPAL LIBS) and $(OPAL_LIBPATH)
??? Error during validation source files.
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RT-LAB offers beta capabilities, allowing users to test LabVIEW panels and the 1/O server.
Please note that such features are not yet completed and may lead to unexpected behaviour.
Beta capabilities are disabled by default; you can enable them as follows (figure below):

Window > Preferences > RT-LAB > Capabilities > Beta-Tester

&) Preferences —— —— — l | =] |_ihj
type filter text Capabilities =T VR
. Col Lib Edit
LD D\:fr rary Eaner Capabilities allow you to enable or disable various product components. These
- -0g Viewer capabilities are grouped according to a set of predefined categories.
P group g9 P g
: PyDev
4 RT-LAR Capabilities: Description
Capabilities [ Operator Use this category to activate all
- Development (3 Developer features that are in Beta state.
> Di sti .
E:gnc.l a D 2 Advanced User- Currently, this includes LabVIEW
+ Bxecution [ | L [Beta-Tester] panels and a basic 'O server.
Hardware
> Simulation tools Please note that using these
Target Detection features may cause unexpected
issues,
’ Restore Qefaults] ’ Apply ]
@:‘ [ QK l ’ Cancel ]
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If you are closing RT-LAB and intend to use a version older than 11.x at a later time, you will
have to exit the software by selecting File > Exit and reconfigure for 10.x. This procedure is
necessary because some properties of older versions are not compatible with this new version
and they must be reconfigured, so that the operating system can launch an older version of RT-
LAB. On the other hand, upgrading from older versions to RT-LAB 11.x is an automatic process
that does not require any special procedure.

& RT-LAB

([ File| Edit Mavigate Search Simulation Run  Tool

7 New b

Open File...

]g Quick Start-up project
Close Ctrl+W
Close All Ctrl+5hift+W
Save Ctrl+5
Save As
Save All Ctrl+5hift+5
Revert
Mowve...

Rename F2

Refresh F5

Print Ctrl+P
Switch Workspace

Restart
Import

C. [

Export

Properties Alt+Enter

i

Open Log Viewer

5 Exit and reconfigure for 10.%
Exit
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COMPATIBILITY

In order to improve the stability and the upcoming features of the software, the following
products are no longer compatible with RT-LAB 11:

e Windows XP: Microsoft ended support of Windows XP in April 2014. As a result,
RT-LAB 11 compatibility with Windows starts from Windows Vista,

e QNX: Support for QNX as a target OS will end with RT-LAB 11.
Please contact OPAL-RT technical support to see how you can migrate to Red Hat
Enterprise Linux,

e MATLAB versions: RT-LAB 11 will end support of MATLAB versions older than R2011B

—
onl<|lo|<|lo|<|o|<|a|<|a|l<|o|l<|al|f]|ao
N[O ||| OO | d| d| N[N ™ ™ < < < n
o o o o o - - - - - - - - - — -
oO|lo|lOoO|O|OC|O|O|OC|O|O|O]| O o | o o ﬂ o
NI NN NN N[N N|N| NN N N N N N
dle|lele|le|le|le|le|le|e|e|e|a|e|a||

4

RT-LAB

10.6.x AR AR AR AR Arararars

RT-LAB

10.7 x A A A A A A I

RT-LAB

11.0.x AR ArARAa N /| ox

* : Partial support of R2013B that does not include Artemis or RT-Events

e OPAL-RT’s TestDrive is no longer supported with RT-LAB 11. The next generation of
the product will be integrated in an upcoming version of RT-LAB,
e OPAL-RT’s Dinamo is no longer supported with RT-LAB 11.

The following products have been updated for RT-LAB 11, please ask for the latest version to be
used with your system:

e Artemis,

¢ RT-Events

For further information regarding the compatibility between RT-LAB 11 and other products,
please refer to the Installation Guide or contact OPAL-RT technical support
(support@opal-rt.com)
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KNOWN ISSUES

If the user loads a RT-LAB 11 workspace in an older version, some components may present
error messages and/or the project explorer may be duplicated.

5 T .
T T

File Edit MNavigate Search Simulation Run Tools Window Help

I| w | i | - - | 4~ | i} | 1] | &~ - | 5 Quick Access i<t | Configuration
Iy Project Explorer i3 = 0 || rtddemol m QuickProject Connections §3 = 0
| - B - N
= T E_:D o |'f % [Cannot instantiate input element factory com.opalrt.rtlab.ui.configuration.editor.ConfigEditorFactory
4 oy Targets 4 gl Targets ‘S for editor id=com.opalrt.rtlab.ui.configuration.editor name=QuickProject Connections
& | Click to discove & | Click to discove -
s 'bn QuickProject > 'bn QuickProject

o Createa new prgje =p Create @ new proje

Display &2 E 3 = B8
Bo&kl¥Y #onEm ~
Mo selection
] 1 (] 1 ¢ L

&3 Progress 23 % T =0

MNo operations to display at this time.

This problem may happen if the user opens perspectives or components (views or editors) from
RT-LAB 11 that do not exist in older versions. Fixing this problem is quite simple: the user
should simply close the incompatible views and editors, close all perspectives and then reopen
them. This problem arises only when migrating from RT-LAB 11 to older versions. For future RT-
LAB versions, the management of perspectives has been improved so that this problem will no
longer happen.
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The handling of network interfaces has been significantly improved, allowing users to operate
RT-LAB on machines with multiple network interfaces, a configuration that was not supported in
previous versions. There are, however, some known issues that may occur in very particular
situations, for example: RT-LAB must be closed and all models must be stopped before any
modification in network configuration (e.qg. if Wi-Fi is activated while using RT-LAB).

Pausing and resuming a model with multiple subsystems per core and Dolphin connections will
make RT-LAB to stop working properly. The following procedure will cause a crash of RT-LAB:
(1) load a model with real-time communication link set to Dolphin (proper hardware required); (2)
run; (3) pause; (4) run. Even if such problem has never been reported by users, it has been
detected during internal tests.
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